Wednesday, April 16th 2014, 3:24pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to Monitoring-Portal.
Although this is a german monitoring forum, please don't hesitate to post in English. Nearly everybody here understands you and will answer in English as well.
If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form to register here or read more information about the registration process. If you are already registered, please login here.

gjfrater

Trainee

Posts: 95

Number of monitoring servers: 1

Nagios Version: 3.0.6

Distributed monitoring: Nein

Redundant monitoring: Nein

Number of hosts: 450

Number of services: 3500

OS: RHEL 5

Plugin Version: 1.4.13

NDO Version: 1

1

Monday, November 29th 2010, 11:20pm

Hover menu off screen - nagvis 1.5.5

Greetings All,

We are testing Nagvis 1.5.5, planning an upgrade from 1.5.1 and having trouble with the hover popup's displaying partly off screen. I am testing with FF 3.6.8, IE 7, and IE 8. It fixes some of the stability issues we are seeing in 1.5.1, we are looking forward to those fixes and other improvements, thank you for those. Below are a couple of screenshots to help display the issue but in summary the problem is that the default pnp hover popups will partly display off screen both to the left or right, depending on length and position of the anchor object on the map. All of them (IE 7 and 8 and FF) will display them off the bottom of the screen. Our hover menu's can be lengthy depending upon the output of the service checks so that does not help. Is there something to change in the NV config files or in the browser settings that effect the hover display?

NV_151_ie7_example shows a hover display in NagVis 1.5.1 and it's able to keep it on screen. NV_155_ie7_example shows the same map and the same hover display being pushed off the screen. The last one NV_155_ff_example shows FF with the same map where the hover display is off the bottom of the screen, all the browsers do this and I suspect there's not much to be done with that. Is anyone else having this issue with the 1.5.5 release?

Thanks,

-greg
gjfrater has attached the following images:
  • NV_151_ie7_example.PNG
  • NV_155_ff_example.PNG
  • NV_155_ie7_example.PNG

This post has been edited 4 times, last edit by "gjfrater" (Dec 7th 2010, 9:36pm)


Hutzli

Beginner

Posts: 2

Number of monitoring servers: 1

Nagios Version: 3.2.0

Distributed monitoring: Nein

Redundant monitoring: Nein

Number of hosts: 100

Number of services: 100

OS: Windows, Linux, Solaris

Plugin Version: ?

NDO Version: 1

2

Friday, December 3rd 2010, 11:52am

Habe das gleiche Problem. Allerdings nur bestimmten Browsern:
Firefox 3.6.12 / Windows XP: kein Problem (s. Bild)
IE8 / Windows XP: Hover-Menüs klappen "unendlich" weit nach links auf, fast kein Text mehr lesbar, selbst bei 30"-Monitor und Vollbild (s. Bild)
IE8 / Windows 2008: kein Problem

Nagvis Version 1.5.5

Ach ja, wer kann mir sagen, in welchem Konfigfile ich die Transparenz in den Hovermenüs ausschalten kann, die macht wenig Sinn?

Vielen Dank
Carsten
Hutzli has attached the following images:
  • nagvis-ie.png
  • nagvis-ff.png

LaMi

Geek

Posts: 3,873

Birthday: Sep 22nd

Gender: male

Location: München

Occupation: Berater / Entwickler

Number of monitoring servers: x

Nagios Version: 3.2.x

Distributed monitoring: Nein

Redundant monitoring: Nein

Number of hosts: x

Number of services: x

OS: SLES,CentOS,Debian

Plugin Version: x

NagVis Version: Git

NDO Version: -

IDO-Version: -

Perfparse Version: -

Other Addons: PNP, Check_MK, Livestatus, Multisite

3

Friday, December 3rd 2010, 7:23pm

Please check out the next/last nightly build. I made some changes in the last days which should fix those problems.

@Hutzli: Die Transparenz war in den vergangenen Fällen immer ein Caching Problem vom Browser. Oder benutz du eventuell ein Custom-Template ohne CSS-Datei?

Regards,
Lars

Hutzli

Beginner

Posts: 2

Number of monitoring servers: 1

Nagios Version: 3.2.0

Distributed monitoring: Nein

Redundant monitoring: Nein

Number of hosts: 100

Number of services: 100

OS: Windows, Linux, Solaris

Plugin Version: ?

NDO Version: 1

4

Monday, December 6th 2010, 11:54am

@Lars:
Vielen Dank!
Habe die letzte nightly build installiert und beide Probleme sind gelöst. Nagvis funktioniert jetzt mit FF und IE gleichermaßen und die Transparenz ist auch verschwunden.

gjfrater

Trainee

Posts: 95

Number of monitoring servers: 1

Nagios Version: 3.0.6

Distributed monitoring: Nein

Redundant monitoring: Nein

Number of hosts: 450

Number of services: 3500

OS: RHEL 5

Plugin Version: 1.4.13

NDO Version: 1

5

Tuesday, December 7th 2010, 9:30pm

Hey Lars,

Those updates did the trick for us here, Thank you. The hover popups in both FF and IE respond the same now, they stay within the left right and top borders of the window. The bottom border is a different issue, it's the same across all browsers I've tested and I'm not sure how you'd get around it but maybe there is a way. On the bottom border hover popups will run off the window. The vertical scroll bar shrinks letting me know the web page is longer but of course you can't get to the bottom of it, as soon as your mouse moves the hover popup goes away and the page returns to it's original size. The NV_155-nightly_example.png image below demonstrates this.


The other two attached images show one small difference between IE and FF in terms of popups, not a big concern for us but I thought it might be something you'd like to see or know about, if you don't already. We have a simplified hover popup that displays the pnp graph with the service check text output above the graph as part of the popup. When displaying long check text output FF wraps the text to match the length of the pnp graph, IE on the other hand does not causing the popup to display in a wierd way. It's a minor nuisance and not a show stopper like the other things you've already fixed.

Thanks again for the hard work,

-greg
gjfrater has attached the following images:
  • NV_155-nightly_FF_example.PNG
  • NV_155-nightly_ie7-8_example.PNG
  • NV_155-nightly_example.PNG

Gwolla

Beginner

Posts: 4

Number of monitoring servers: 1

Nagios Version: 3

Distributed monitoring: Ja

Redundant monitoring: Nein

Number of hosts: 50

Number of services: 250

OS: debian

Plugin Version: 1.5.6

NDO Version: 1

6

Wednesday, January 5th 2011, 10:56pm

Related issue

Hi there,

First of all, many thanks for this wonderfull tool!

I'm afraid I have related issues as the original poster had. I am using the latest version, 1.5.6.

When I mouse over (hover) on a certain item on my map which is close to the bottom the popup partly shows on my screen and increases my page downwards but I cannot scroll down without losing the popup. I've tried some different browsers, Google's Chrome occassionaly allows me to scroll down if I keep my mouse still. Other browsers will not.

Is there not a way to maybe make this popup "sticky" or replace it with a left/right mouse click that popups a screen to be manually closed?

See the screenshot for clarification, notice the scroll bar.



Thanks for any help in advance!



Regards,

Rob
Gwolla has attached the following image:
  • hover.png

Similar threads